// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)# From object name = value
( # (1 start)
" \s* \w+ \s* " \s* :
(?! \s* " ) # not a string
(?! # not a number
\s* \d+ \s*
(?: , | \] | } )
)
(?! \s* [{\[] ) # not a object or array
(?! # not true,false or null
\s*
(?: true | false | null )
\s*
(?: , | \] | } )
)
\s*
) # (1 end)
( .+? ) # (2)
(?= [,}] )"#).unwrap();
let string = " {\"Id\": \"2017\",
\"Currency\": \"AUD\",
\"Date\": 2020-06-22,
\"InCash\": 0.000,
\"Dep\": \"ABC90\",
\"sdf\" : 739,
\"sumCash\": 770.87,
\"AnotherDate\": 2020-06-21}";
let substitution = "$1\"$2\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}