$re = '/# From object name = value
( # (1 start)
" \s* \w+ \s* " \s* :
(?! \s* " ) # not a string
(?! # not a number
\s* \d+ \s*
(?: , | \] | } )
)
(?! \s* [{\[] ) # not a object or array
(?! # not true,false or null
\s*
(?: true | false | null )
\s*
(?: , | \] | } )
)
\s*
) # (1 end)
( .+? ) # (2)
(?= [,}] )/x';
$str = ' {"Id": "2017",
"Currency": "AUD",
"Date": 2020-06-22,
"InCash": 0.000,
"Dep": "ABC90",
"sdf" : 739,
"sumCash": 770.87,
"AnotherDate": 2020-06-21}';
$subst = "$1\"$2\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;