# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
# From object name = value
( # (1 start)
" \s* \w+ \s* " \s* :
(?! \s* " ) # not a string
(?! # not a number
\s* \d+ \s*
(?: , | \] | } )
)
(?! \s* [{\[] ) # not a object or array
(?! # not true,false or null
\s*
(?: true | false | null )
\s*
(?: , | \] | } )
)
\s*
) # (1 end)
( .+? ) # (2)
(?= [,}] )
"""
test_str = (" {\"Id\": \"2017\",\n"
" \"Currency\": \"AUD\",\n"
" \"Date\": 2020-06-22,\n"
" \"InCash\": 0.000, \n"
" \"Dep\": \"ABC90\",\n"
" \"sdf\" : 739,\n"
" \"sumCash\": 770.87,\n"
" \"AnotherDate\": 2020-06-21}")
subst = "$1\"$2\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.