using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#([^\b#,() ]*)\b";
string input = @"#hot#hot hot #hot #hot.hot #hót #hot_hot #hot, (#hot) #hot. hot";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}