re = /#([^\b#,() ]*)\b/
str = '#hot#hot hot #hot #hot.hot #hót #hot_hot #hot, (#hot) #hot. hot'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end