$re = '/#([^\b#,() ]*)\b/';
$str = '#hot#hot hot #hot #hot.hot #hót #hot_hot #hot, (#hot) #hot. hot';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);