using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)((core\/)?misc\/drupal\.js)";
string input = @"installations/si/drupal-4test/misc/drupal.js
installations/si/drupal-8.1.0/core/misc/drupal.js
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}