const regex = new RegExp('(.*?)((core\\/)?misc\\/drupal\\.js)', 'g')
const str = `installations/si/drupal-4test/misc/drupal.js
installations/si/drupal-8.1.0/core/misc/drupal.js
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}