re = /(.*?)((core\/)?misc\/drupal\.js)/
str = 'installations/si/drupal-4test/misc/drupal.js
installations/si/drupal-8.1.0/core/misc/drupal.js
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end