package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*?)((core\/)?misc\/drupal\.js)`)
var str = `installations/si/drupal-4test/misc/drupal.js
installations/si/drupal-8.1.0/core/misc/drupal.js
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}