package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((\\x[\d]{2}){4,}.*)`)
var str = `"\x01\x00\x00\x00\x05\x00\x00\x00\x00\x00\x00\x00X\x1D›¿\x04\x04›?‹„\x12¿Ã’\x11?"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}