using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[-+]?([1-9][0-9]*\.|0\.)?[0-9]+([eE][-+]?[0-9]+)?$";
string input = @"0.000000
-0.00000
+0.0000
.1
+.1
-.1
+00000.1
-00000.1
000000000000000.1
000.1111
00.11
0.1
-0.1
+0.1
1.1
+1.1
-1.1
10.11
+10.11
+10.11
100.11
+100.11
-100.11
1000.111
+1000.111
-1000.111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}