// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[-+]?([1-9][0-9]*\.|0\.)?[0-9]+([eE][-+]?[0-9]+)?$").unwrap();
let string = "0.000000
-0.00000
+0.0000
.1
+.1
-.1
+00000.1
-00000.1
000000000000000.1
000.1111
00.11
0.1
-0.1
+0.1
1.1
+1.1
-1.1
10.11
+10.11
+10.11
100.11
+100.11
-100.11
1000.111
+1000.111
-1000.111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}