const regex = /^[-+]?([1-9][0-9]*\.|0\.)?[0-9]+([eE][-+]?[0-9]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[-+]?([1-9][0-9]*\\.|0\\.)?[0-9]+([eE][-+]?[0-9]+)?$', 'gm')
const str = `0.000000
-0.00000
+0.0000
.1
+.1
-.1
+00000.1
-00000.1
000000000000000.1
000.1111
00.11
0.1
-0.1
+0.1
1.1
+1.1
-1.1
10.11
+10.11
+10.11
100.11
+100.11
-100.11
1000.111
+1000.111
-1000.111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}