import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[-+]?([1-9][0-9]*\\.|0\\.)?[0-9]+([eE][-+]?[0-9]+)?$";
final String string = "0.000000\n"
+ "-0.00000\n"
+ "+0.0000\n"
+ ".1\n"
+ "+.1\n"
+ "-.1\n"
+ "+00000.1\n"
+ "-00000.1\n"
+ "000000000000000.1\n"
+ "000.1111\n"
+ "00.11\n"
+ "0.1\n"
+ "-0.1\n"
+ "+0.1\n"
+ "1.1\n"
+ "+1.1\n"
+ "-1.1\n"
+ "10.11\n"
+ "+10.11\n"
+ "+10.11\n"
+ "100.11\n"
+ "+100.11\n"
+ "-100.11\n"
+ "1000.111\n"
+ "+1000.111\n"
+ "-1000.111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}