using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"uns://(([a-z]|[A-Z]|[0-9]|-)+)/";
string input = @"uns://dca1/dca1-prod06/us1/service/environment/partition";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}