// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"uns://(([a-z]|[A-Z]|[0-9]|-)+)/").unwrap();
let string = "uns://dca1/dca1-prod06/us1/service/environment/partition";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}