re = /uns:\/\/(([a-z]|[A-Z]|[0-9]|-)+)\//
str = 'uns://dca1/dca1-prod06/us1/service/environment/partition'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end