$re = '/uns://(([a-z]|[A-Z]|[0-9]|-)+)//';
$str = 'uns://dca1/dca1-prod06/us1/service/environment/partition';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);