using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(bla)|(?<quote>\[quote\].*((?"e).*)*\[\/quote(*SKIP)\])(*F)|[^=]((?1))";
string input = @"bla
=bla
!=bla
!bla
[quote]bla[/quote]
[quote] bla [/quote]
[quote][/quote]bla
[quote][/quote] bla
[quote][/quote]bla
[quote][quote] ... [/quote] bla[/quote]
[quote][quote] ... [/quote] bla[/quote] bla!
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}