$re = '/^(bla)|(?<quote>\[quote\].*((?"e).*)*\[\/quote(*SKIP)\])(*F)|[^=]((?1))/';
$str = 'bla
=bla
!=bla
!bla
[quote]bla[/quote]
[quote] bla [/quote]
[quote][/quote]bla
[quote][/quote] bla
[quote][/quote]bla
[quote][quote] ... [/quote] bla[/quote]
[quote][quote] ... [/quote] bla[/quote] bla!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);