re = /^(bla)|(?<quote>\[quote\].*((?"e).*)*\[\/quote(*SKIP)\])(*F)|[^=]((?1))/
str = 'bla
=bla
!=bla
!bla
[quote]bla[/quote]
[quote] bla [/quote]
[quote][/quote]bla
[quote][/quote] bla
[quote][/quote]bla
[quote][quote] ... [/quote] bla[/quote]
[quote][quote] ... [/quote] bla[/quote] bla!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end