import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(bla)|(?<quote>\\[quote\\].*((?"e).*)*\\[\\/quote(*SKIP)\\])(*F)|[^=]((?1))";
final String string = "bla\n"
+ "=bla\n"
+ "!=bla\n"
+ "!bla\n"
+ "[quote]bla[/quote]\n"
+ "[quote] bla [/quote]\n"
+ "[quote][/quote]bla\n"
+ "[quote][/quote] bla\n"
+ "[quote][/quote]bla\n"
+ "[quote][quote] ... [/quote] bla[/quote]\n"
+ "[quote][quote] ... [/quote] bla[/quote] bla!\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}