#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)link to (?<keyword>[a-z ]+) from (?<name>[a-z ]+)(?=shared)?(?<time>[a-z]+)?"
Local $sString = "link to connect link from sandeep akula" & @CRLF & _
"link to sharepoint git from sapna" & @CRLF & _
"link to sharepoint git from sapna grover shared yesterday" & @CRLF & _
"" & @CRLF & _
"sharepoint git link form sapna shared yesterday"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")