import Foundation
let pattern = #"link to (?<keyword>[a-z ]+) from (?<name>[a-z ]+)(?=shared)?(?<time>[a-z]+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
link to connect link from sandeep akula
link to sharepoint git from sapna
link to sharepoint git from sapna grover shared yesterday
sharepoint git link form sapna shared yesterday
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)