import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "link to (?<keyword>[a-z ]+) from (?<name>[a-z ]+)(?=shared)?(?<time>[a-z]+)?";
final String string = "link to connect link from sandeep akula\n"
+ "link to sharepoint git from sapna\n"
+ "link to sharepoint git from sapna grover shared yesterday\n\n"
+ "sharepoint git link form sapna shared yesterday";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}