$re = '/link to (?<keyword>[a-z ]+) from (?<name>[a-z ]+)(?=shared)?(?<time>[a-z]+)?/i';
$str = 'link to connect link from sandeep akula
link to sharepoint git from sapna
link to sharepoint git from sapna grover shared yesterday
sharepoint git link form sapna shared yesterday';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);