#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b((?:AAA|BBC|CCC)(?=\d{3}\b)|(?:ZZ|XX|YY)(?=\d{2}\b))"
Local $sString = "AAA031 but not AAA00 and match ZZ00" & @CRLF & _
"AAA031" & @CRLF & _
"AAA0312" & @CRLF & _
"AAA02" & @CRLF & _
"AAA0" & @CRLF & _
"ZZ00" & @CRLF & _
"ZZ211"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")