import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:AAA|BBC|CCC)(?=\\d{3}\\b)|(?:ZZ|XX|YY)(?=\\d{2}\\b))";
final String string = "AAA031 but not AAA00 and match ZZ00\n"
+ "AAA031\n"
+ "AAA0312\n"
+ "AAA02\n"
+ "AAA0\n"
+ "ZZ00\n"
+ "ZZ211";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}