$re = '/\b((?:AAA|BBC|CCC)(?=\d{3}\b)|(?:ZZ|XX|YY)(?=\d{2}\b))/';
$str = 'AAA031 but not AAA00 and match ZZ00
AAA031
AAA0312
AAA02
AAA0
ZZ00
ZZ211';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);