const regex = new RegExp('\\b((?:AAA|BBC|CCC)(?=\\d{3}\\b)|(?:ZZ|XX|YY)(?=\\d{2}\\b))', 'g')
const str = `AAA031 but not AAA00 and match ZZ00
AAA031
AAA0312
AAA02
AAA0
ZZ00
ZZ211`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}