import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?:OOO) # \"OOO\"\n"
+ "(ABC|DEF) # \"ABC\" or \"DEF\"\n"
+ "(RR|AA|DD|EE) # \"RR\" or \"AA\" or \"DD\" ior :\"EE)\n"
+ "(\n"
+ " (?:AAA|BBC|CCC)(?=\\d{3}\\b) # \"AAA\" or \"BBB\" or \"CCC\" if followed by 3 digits\n"
+ " | # or\n"
+ " (?:ZZ|XX|YY)(?=\\d{2}\\b) # \"ZZ\" or \"XX\" or \"YY\" if followed by 2 digits\n"
+ ")\n"
+ ".* # anything up to the end\n"
+ "$";
final String string = "OOODEFDDAAA011\n"
+ "OOODEFDDZZ01\n"
+ "OOODEFDDZZ011\n"
+ "OOODEFDDZZ01 words at the end?";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}