# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^
(?:OOO) # "OOO"
(ABC|DEF) # "ABC" or "DEF"
(RR|AA|DD|EE) # "RR" or "AA" or "DD" ior :"EE)
(
(?:AAA|BBC|CCC)(?=\d{3}\b) # "AAA" or "BBB" or "CCC" if followed by 3 digits
| # or
(?:ZZ|XX|YY)(?=\d{2}\b) # "ZZ" or "XX" or "YY" if followed by 2 digits
)
.* # anything up to the end
$
"""
test_str = ("OOODEFDDAAA011\n"
"OOODEFDDZZ01\n"
"OOODEFDDZZ011\n"
"OOODEFDDZZ01 words at the end?")
matches = re.finditer(regex, test_str, re.VERBOSE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.