re = /^
(?:OOO) # "OOO"
(ABC|DEF) # "ABC" or "DEF"
(RR|AA|DD|EE) # "RR" or "AA" or "DD" ior :"EE)
(
(?:AAA|BBC|CCC)(?=\d{3}\b) # "AAA" or "BBB" or "CCC" if followed by 3 digits
| # or
(?:ZZ|XX|YY)(?=\d{2}\b) # "ZZ" or "XX" or "YY" if followed by 2 digits
)
.* # anything up to the end
$/xm
str = 'OOODEFDDAAA011
OOODEFDDZZ01
OOODEFDDZZ011
OOODEFDDZZ01 words at the end?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end