// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?xm)^
(?:OOO) # "OOO"
(ABC|DEF) # "ABC" or "DEF"
(RR|AA|DD|EE) # "RR" or "AA" or "DD" ior :"EE)
(
(?:AAA|BBC|CCC)(?=\d{3}\b) # "AAA" or "BBB" or "CCC" if followed by 3 digits
| # or
(?:ZZ|XX|YY)(?=\d{2}\b) # "ZZ" or "XX" or "YY" if followed by 2 digits
)
.* # anything up to the end
$"#).unwrap();
let string = "OOODEFDDAAA011
OOODEFDDZZ01
OOODEFDDZZ011
OOODEFDDZZ01 words at the end?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}