#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(man|\Miss|\Mrs)\-?\.?"
Local $sString = "man" & @CRLF & _
"mankind" & @CRLF & _
"man-made" & @CRLF & _
"common man" & @CRLF & _
"chairman" & @CRLF & _
"mailman" & @CRLF & _
"policeman" & @CRLF & _
"fireman" & @CRLF & _
"salesman" & @CRLF & _
"saleswoman" & @CRLF & _
"congresswoman" & @CRLF & _
"Miss" & @CRLF & _
"Mrs."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")