import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(man|\\Miss|\\Mrs)\\-?\\.?";
final String string = "man\n"
+ "mankind\n"
+ "man-made\n"
+ "common man\n"
+ "chairman\n"
+ "mailman\n"
+ "policeman\n"
+ "fireman\n"
+ "salesman\n"
+ "saleswoman\n"
+ "congresswoman\n"
+ "Miss\n"
+ "Mrs.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}