re = /(man|\Miss|\Mrs)\-?\.?/m
str = 'man
mankind
man-made
common man
chairman
mailman
policeman
fireman
salesman
saleswoman
congresswoman
Miss
Mrs.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end