$re = '/(man|\Miss|\Mrs)\-?\.?/m';
$str = 'man
mankind
man-made
common man
chairman
mailman
policeman
fireman
salesman
saleswoman
congresswoman
Miss
Mrs.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);