import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<field_with_params>[^\\{ \\}]+(?P<parenth_open>\\()(?P<keyword>[^\\(\\s]\\w+)\\s?(?P<colon>\\:)\\s?(?P<value>(?P<list_open>\\[?).+?(?P<list_close>\\]?))\\s?(?P<parenth_close>\\)))|(?P<BEGIN>^\\{)|(?P<open>\\{)|(?P<END>\\}$)|(?P<close>\\})|(?P<fragment>(?P<dots>\\.{3})\\s*?(?P<on>on)\\s+?(?P<frag_field>\\w+))|(?P<parent_field>(?!(?P=field_with_params)|(?P=fragment))\\w+)(?=\\s*?\\{)|(?P<child_field>(?!(?P=field_with_params)|(?P=fragment))\\w+)";
final String string = "{analyticsMetadata(ids: [\"37210161\"]) {video { originalProgramTitle productionYear } episode($blah: 'asdf') { name nameRaw number ... on Single { name id } shortDescription longDescription urls { svtplay } } title { __typename slug id svtId name longDescription shortDescription accessibilities urls { svtplay } } name id producingDepartmentId producingDepartmentName seasonId seasonName seasonNumber seasonProducedEpisodes seasonYear svtId typeName} }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}