import Foundation
let pattern = #"(?P<field_with_params>[^{ }]+(?P<parenth_open>\()(?P<keyword>[^\(\s]\w+)\s?(?P<colon>\:)\s?(?P<value>(?P<list_open>\[?).+?(?P<list_close>\]?))\s?(?P<parenth_close>\)))|(?P<BEGIN>^\{)|(?P<open>\{)|(?P<END>\}$)|(?P<close>\})|(?P<fragment>(?P<dots>\.{3})\s*?(?P<on>on)\s+?(?P<frag_field>\w+))|(?P<parent_field>(?!(?P=field_with_params)|(?P=fragment))\w+)(?=\s*?\{)|(?P<child_field>(?!(?P=field_with_params)|(?P=fragment))\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{analyticsMetadata(ids: ["37210161"]) {video { originalProgramTitle productionYear } episode($blah: 'asdf') { name nameRaw number ... on Single { name id } shortDescription longDescription urls { svtplay } } title { __typename slug id svtId name longDescription shortDescription accessibilities urls { svtplay } } name id producingDepartmentId producingDepartmentName seasonId seasonName seasonNumber seasonProducedEpisodes seasonYear svtId typeName} }"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)