use strict;
my $str = '{analyticsMetadata(ids: ["37210161"]) {video { originalProgramTitle productionYear } episode($blah: \'asdf\') { name nameRaw number ... on Single { name id } shortDescription longDescription urls { svtplay } } title { __typename slug id svtId name longDescription shortDescription accessibilities urls { svtplay } } name id producingDepartmentId producingDepartmentName seasonId seasonName seasonNumber seasonProducedEpisodes seasonYear svtId typeName} }';
my $regex = qr/(?P<field_with_params>[^{ }]+(?P<parenth_open>\()(?P<keyword>[^\(\s]\w+)\s?(?P<colon>\:)\s?(?P<value>(?P<list_open>\[?).+?(?P<list_close>\]?))\s?(?P<parenth_close>\)))|(?P<BEGIN>^\{)|(?P<open>\{)|(?P<END>\}$)|(?P<close>\})|(?P<fragment>(?P<dots>\.{3})\s*?(?P<on>on)\s+?(?P<frag_field>\w+))|(?P<parent_field>(?!(?P=field_with_params)|(?P=fragment))\w+)(?=\s*?\{)|(?P<child_field>(?!(?P=field_with_params)|(?P=fragment))\w+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}