re = /(?P<field_with_params>[^{ }]+(?P<parenth_open>\()(?P<keyword>[^\(\s]\w+)\s?(?P<colon>\:)\s?(?P<value>(?P<list_open>\[?).+?(?P<list_close>\]?))\s?(?P<parenth_close>\)))|(?P<BEGIN>^\{)|(?P<open>\{)|(?P<END>\}$)|(?P<close>\})|(?P<fragment>(?P<dots>\.{3})\s*?(?P<on>on)\s+?(?P<frag_field>\w+))|(?P<parent_field>(?!(?P=field_with_params)|(?P=fragment))\w+)(?=\s*?\{)|(?P<child_field>(?!(?P=field_with_params)|(?P=fragment))\w+)/m
str = '{analyticsMetadata(ids: ["37210161"]) {video { originalProgramTitle productionYear } episode($blah: \'asdf\') { name nameRaw number ... on Single { name id } shortDescription longDescription urls { svtplay } } title { __typename slug id svtId name longDescription shortDescription accessibilities urls { svtplay } } name id producingDepartmentId producingDepartmentName seasonId seasonName seasonNumber seasonProducedEpisodes seasonYear svtId typeName} }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end