#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0|[1-9]\d*)(\.)?(\d*)?$"
Local $sString = "121123/\3465346ss" & @CRLF & _
"5/\3465346" & @CRLF & _
"3/\\\01777" & @CRLF & _
"3\017773\" & @CRLF & _
"225555.25544444" & @CRLF & _
"22.22" & @CRLF & _
"222.22" & @CRLF & _
"222.5555555"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")