use strict;
my $str = '121123/\\3465346ss
5/\\3465346
3/\\\\\\01777
3\\017773\\
225555.25544444
22.22
222.22
222.5555555';
my $regex = qr/^(0|[1-9]\d*)(\.)?(\d*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}