import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0|[1-9]\\d*)(\\.)?(\\d*)?$";
final String string = "121123/\\3465346ss\n"
+ "5/\\3465346\n"
+ "3/\\\\\\01777\n"
+ "3\\017773\\\n"
+ "225555.25544444\n"
+ "22.22\n"
+ "222.22\n"
+ "222.5555555";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}