re = /^(0|[1-9]\d*)(\.)?(\d*)?$/m
str = '121123/\\3465346ss
5/\\3465346
3/\\\\\\01777
3\\017773\\
225555.25544444
22.22
222.22
222.5555555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end