#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*\S)\n(?!\n)"
Local $sString = "this line should have a break" & @CRLF & _
"and this one" & @CRLF & _
"but not this one" & @CRLF & _
"" & @CRLF & _
"and this one should" & @CRLF & _
"and this one" & @CRLF & _
"but not this one" & @CRLF & _
"" & @CRLF & _
"and so on"
Local $sSubst = "$1 \n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)