const regex = /(.*\S)\n(?!\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*\\S)\\n(?!\\n)', 'gm')
const str = `this line should have a break
and this one
but not this one
and this one should
and this one
but not this one
and so on`;
const subst = `$1 \n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);