import re
regex = re.compile(r"(.*\S)\n(?!\n)", flags=re.MULTILINE)
test_str = ("this line should have a break\n"
"and this one\n"
"but not this one\n\n"
"and this one should\n"
"and this one\n"
"but not this one\n\n"
"and so on")
subst = "$1 \\n"
result = regex.sub(subst, test_str)
if result:
print(result)